Hello developer. Login with your existing account. New to Vodafone Developer? Register your account.

+ Login or create an account

0

Hi everybody.

Sorry to bother 'u, but I'm new here.

I just will be glad to know if anybody here can help me understanding how to connect an italian Vodafone Internet Key

http://www.areaprivati.vodafone.it/190/trilogy/jsp/programView.do?contentKey=29215&pageTypeId=9609&channelId=-8671&programId=9390&tk=HPPrivati%2CP1Cright&ty_key=pri_Internet_offerta_facile

with an Asus Eee PC 901 running GNU Linux

http://www.asus.it/products.aspx?l1=24&l2=164&l3=0&l4=0&model=2283&modelmenu=2

Can anybody help me ?

Thankyou in advance !
Kind regards,
ll

114 Answers:

0
Hi Lazarus, Follow the repository setup at http://www.betavine.net/bvportal/application/linux_drivers/repository Then use the following settings when asked to create a new profile to connect to VF-IT APN web.omnitel.it USER * PASS * I think the USER and PASS can be anything, so I entered '*', Hope that helps, Andrew
0
Thankyou Andrewbird! I'll try a.s.a.p. (as soon as I can put my paws on the Eee PC I had just ordered), and I'll tell here if everything went fine or not. ll
0
Hi Andrew, I'm still waiting for the Vodafone Internet Key I had ordered, but I had received my eee901. While waiting for my vodafone key I decided to add Betavine to my repository, I followed all the procedures described here http://www.betavine.net/bvportal/application/linux_drivers/repository up to "The software will now be installed by the package management system. Quit synaptic, and exit the terminal window." I did, but the system rebooted and all the graphical interface was completely lost. I tried to reboot a few times, without succes, tried (with F9) to restore factory settings keeping user data, but even this procedure was useless. In the end I did a full restore to factory settings that gave me back a fully working virgin asus eee pc 901. But all user data were lost (luckily I had just started to play with his new netbook, so I hadn't really lost anything valuable). Now I'm again with a virgin system, but something went wrong with vodafone mobile connect package installation. Can anybody help me ? Thankyou in advance. ll
0
Just adding that a few moments ago I had retried to install again the same package in the betavine repository in a system that was virgin and clean as a whistle (I had just installed the software upgrades that were requested by the virgin system (I had done the same also the first time after having unwrapped the brand new eeepc) ). Same result: the graphical interface is lost and all I can do is restore factory settings (F9 key pressed while booting). I'm a newborn in Linux, but I have a few decades of experience as Microstuff user (from DOS 2.0 onwards). I can't imagine what could I have done wrong in a so simple installation ! Thankyou in advance to anybody that can be so kind to help me...
0
Lazarus It sounds as if you have enabled some other repositories, which are overwriting some of the packages already on the EEE. The Betavine repo alone should not be capable of doing this, as there are no such packages in the system. Please can you open a terminal, and type: kate /etc/apt/sources.list and post the output here?
0
Hi Neil: it seems it is connected just with the standard repositories: deb http://update.eeepc.asus.com/1.6 common main deb http://update.eeepc.asus.com/1.6 p901 main deb http://update.eeepc.asus.com/1.6 it-channel main And I assume that the same situation was in place before the reset I was forced to perform after the crash yesterday night, because I hadn't fiddled with anything yet on this one week old netbook, apart from this connection stuff. Could it be that there is a problem with the localization of Eee Pcs sold in Italy ? Thankyou for helping me !
0
Now I had tried again. The sources that I can see listed now are the same standard three plus one blank line (?) plus: http://betavine.net/repo/debian/dist/etch/ EeePC/. This time the graphical interface has survived, but no Vodafone icon is present anywhere. Moreover, only at the fourth boot I was able to obtain a terminal window (the first three attempts seemed ok but nothing happened while pressing ctrl+alt+t as usual). Sorry but all this doesn't seem very stable and serious... I'm thinking to reset factory settings for the fourth time but I'm not sure I'll like to continue experiments that produce so unpredictable results. Luckily my vodafone internet key has not arrived yet and I'm seriously considering the possibility not to subscribe the contract at all.
0
It would seem that there is a bug which is causing a problem with an Italian machine - I've just tested this on a fresh EEE 701, with no problem at all (just the installation; I didn't check the connection). Do bear in mind that any software can cause problems- just look at the havoc Internet Explorer is wreaking on the world right now!
0
Ok, I courageously restored factory configuration for the n-th time and, immediately after reboot, I installed just the customary upgrades the system is asking to download from asus repositories. Then I followed betavine instructions and configured synaptics to look at betavine repository and downloaded and installed the vodafone-moble-connect package. This time I obtained the following result: the graphical interface is still working (it was missing the first time), the terminal is still present (it wasn't present anymore the second time), but the vodafone icon is not present on the internet folder (as it happened the second time, while the first time all the graphics was missing at all). Better than before, because I had obtained a system ... practically working as a new one... but no VNC connection at all. The installed repositories are: deb http://update.eeepc.asus.com/1.6 common main deb http://update.eeepc.asus.com/1.6 p901 main deb http://update.eeepc.asus.com/1.6 it-channel main deb http://betavine.net/repo/debian/dist/etch/ EeePC/. (there is a blank line between the first three and the last entry). I wonder how I'm obtaining three completely different results, (note that none of them is satisfying) performing exactly the same operation on a system that each time had just been restored to the same factory defaults. Is it possible to see if, by chance, the VNC is present and correctly installed but just the icon is missing ? Any suggestion is welcome and will be greatly apreciated. Thankyou in advance.
0
Hi the only way we have noticed the icon being missing is if you do a sofware upgrade with Asus repo's after installing the driver. (This may be resolved by Asus) But I remember earlier in the year noticing that a certain version of upgrade would replace the SIMPLEUI.RC file with new icons and menus, instead of adding the relevant lines into the file as the VMC post install script does. However you say that you upgraded first and then added the VMC driver!? You can run the VMC software from the command line. Use:
 /home/user> vodafone-mobile-connect-card-driver-for-linux 
To start in debug mode and get output to the screen use:
 /home/user> vodafone-mobile-connect-card-driver-for-linux-debug 
Hava a look in /opt/vmc to see this directory is in place. Also have a look for directory /home/user/.vmc2 Sorry to hear you are having so many problems with this! Kind regards, Nicholas.
0
The last entry does not look right- I do not believe that there should be a space between "/etch/" and "EeePC", and there should not be a full stop at the end. In terms of running VMC (VNC is something very different), try: sudo vodafone-mobile-connect-card-driver-for-linux
0
Hi Neil, Lazarus, I've checked the URI out and whilst I agree about the trailing '.' not being required, the space is correct. It seems that the Synaptic part is working since there's no mention of an error message there. Lazarus, can you post the exact name and version number of the rescue CD you used? I'll try to get hold of one if I can.
0
Interesting - thanks, Andrew.
0
Hi Neil. Thankyou for your help, but...are you completely sure of: > I do not believe that there should be a space > between "/etch/" and "EeePC", and there should not be a > full stop at the end. ? Because in the previous three standard repo entries there is always a space separating the url from the distribution record, and all three previous entries end with a fullstop, at least as far as seeing them through kate is concerned. Moreover, on my pc synaptics effectively downloaded and tried to install a sensible bunch of stuff, so I suppose that the path of the repo is correct, otherwise it should simply have answered that it can't find the repo or the distribution. Right ? If I open synaptic and search for the list of the repo already archived, I see the four entries (three standard+betavine) apparently sintactically correct (in fact, I had noticed yust now, the distribution entry lacks the fullstop at the end in all four of them). Perplexed... ll
0
Lazarus My apologies - absolutely right about the space (sorry, I wasn't thinking about how package repositories are structured), but, the full stop should not be there. However, as you have said, Synaptic is working, so, that is not the cause of your problem.
0
Hi Nicholas, /home/user> vodafone-mobile-connect-card-driver-for-linux produced at the command line the following output: Stopping hardware abstraction layer: hald. Stopping system message bus: dbus. Stopping system message bus: dbus. Starting hardware abstraction layer: hald. and a graphical window opened labelled "X Selezione periferica" (something like "peripherical or external device selection"). It just asks to define and configure an external device inserting type, data port, control port and connection speed. Obviously it can't find anything since I'm still waiting to receive the Vodafone Internet Key I ordered only one month and one day ago... Is it the correct window ? The directory /opt/vmc is in place, and even /home/user/.vmc2 is present. lazarus PS: Andrewbird, I hadn't used a resque CD (no CD drive present and none was installed yet). I simply found reference in the (very thin) manual that pressing F9 during reboot could allow reset to factory settings and I did it. At the moment I consider myself a pro in resetting to factory settings an Asus EeePC 901: I had done it five times in 24 hours... ;-)
0
Lazarus, That's looking good so far, you'll need the device before you can go much further. To find out why the desktop icon installation is broken. Could you send me the following files please? /opt/xandros/share/AsusLauncher/simpleui.rc /opt/xandros/share/AsusLauncher/simpleui.rc.vmc.inst /var/lib/AsusLauncher/simpleui.rc # if it exists Yes I understand about you not needing to use the rescue CD, but package creation/testing has been done on a 701 system, so there might be differences on a 901. I was hoping that a description of that CD might help me to get hold of one for testing. Best regards, Andrew
0
Andrew - check the Asus FTP site - they used to have the recovery CD for the 701 as a image, from memory, and they might have put the 901 image up there too... Just clutching at straws, though.
0
Neil, Thanks. I've just had a good look around the EeePC section of the Asus FTP site, but unfortunately I can find neither 701 or 901 images. It's mainly XP stuff, except for manuals and a 1.8GB Linux source file for the 701.
0
Hmm... I will see what I can find, if anything...
0
Hi Lazarus, This is a busy wee thread, I've only been gone a few hours and it's grown! I'll pull out of the thread now as Andrew can handle best. However I'll just confirm some bits: 1) Looks like the application is installed, the output you get is exactly what I get for starting the app on command line with no card installed. 2) The window is allowing you to pick your card type. I have a favour to ask. Can you go to the route of your file system. i.e. \\> . Do a search on the following file:
 />find -name simpleui.rc 
. You should see something like this:
 ./opt/xandros/share/AsusLauncher/simpleui.rc
find: ./.kde: No such file or directory
find: ./.config: No such file or directory 
I'm hoping that there is only one file and it's in this location! :-) ... Now if you feel up to it. (I'm guessing you are having re-installed several times now!) You could add the following entry into that file via a text editor. If you do please pleas please copy the original file before changing it. Below is the entry you need to add after the firefox one:
<parcel simplecat="Internet" shortcut="/usr/share/applications/vmc.desktop"
	icon="vodafone_norm.png" 
	selected_icon="vodafone_hi.png">
	<name lang="en">Mobile Connect</name>	
	<name lang="zh_TW">Mobile Connect</name>	
	<name lang="zh_HK">Mobile Connect</name>	
	<name lang="zh_CN">Mobile Connect</name>	
	<name lang="ar_AE">Mobile Connect</name>	
	<name lang="de_DE">Mobile Connect</name>	
	<name lang="es_AR">Mobile Connect</name>	
	<name lang="es_ES">Mobile Connect</name>	
	<name lang="fr_FR">Mobile Connect</name>	
	<name lang="it_IT">Mobile Connect</name>	
	<name lang="nl_NL">Mobile Connect</name>	
	<name lang="pt_PT">Mobile Connect</name>	
	<name lang="ru_RU">Mobile Connect</name>	
	<name lang="th_TH">Mobile Connect</name>	
	<name lang="tr_TR">Mobile Connect</name>	
	<name lang="ja_JP">Mobile Connect</name>	
	<name lang="ko_KR">Mobile Connect</name>	
	<name lang="cs_CZ">Mobile Connect</name>	
	<name lang="hu_HU">Mobile Connect</name>	
	<name lang="sk_SK">Mobile Connect</name>	
	<name lang="el_GR">Mobile Connect</name>	
	<name lang="pl_PL">Mobile Connect</name>	
</parcel> 
I'll watch this thread to see how things progress! :-)... Kind regards, Nicholas.
0
Gosh...is anybody here NOT helping me ? ;-) I can't belive hom much kind you are with just another newborn linux rookie ! Back to business then... I have here all three files asked by Andrewbird, and as soon as I reach home tonight I'll send here the exact codenumber of the rescue CD included in the shipment (and never used yet). Can you suggest a good way to send the asked files ? I'm not able to see any email address... Thankyou to all the bunch ! ll
0
Hi Nicholas /> find - name simpleui.rc produces a huge set of results: ./var/lib/AsusLauncher/simpleui.rc ./usr/share/xlex/res/simpleui.rc ./simpleui.rc ./opt/xandros/share/AsusLauncher/simpleui.rc ./opt/iqchinese/simpleui.rc ./.ro/usr/share/xlex/res/simpleui.rc ./.ro/opt/xandros/share/AsusLauncher/simpleui.rc ./.ro/opt/iqchinese/simpleui.rc ./.rw/var/lib/AsusLauncher/simpleui.rc ./.rw/simpleui.rc ./.rw/opt/xandros/share/AsusLauncher/simpleui.rc ./ro/usr/share/xlex/res/simpleui.rc ./ro/opt/xandros/share/AsusLauncher/simpleui.rc ./ro/opt/iqchinese/simpleui.rc Ok, and now please confirm that of all those simpleui.rc files I have to modify exactly ./opt/xandros/share/AsusLauncher/simpleui.rc inserting the lines you suggested in the script (it's the recipe for the "die hard" guys to make the vodafone icon appear in the graphical interface, right) ? Thankyou everybody, ll
0
Uack ! I discovered just now that the lines <parcel simplecat="Internet" shortcut="/usr/share/applications/vmc.desktop" icon="vodafone_norm.png" ... suggested by Nicholas are already present in /opt/xandros/share/AsusLauncher/simpleui.rc exactly where they should be, entirely what they should be, and without any visible syntax error. Shal we call Sherlock Holmes or what ? ;-)
0
Just the last bit of information...maybe it helps you angels. The task manager icon that is placed on the lower right of the screen, normally is a green square, but since the first automatic upgrade (just after the reset) has changed to a yellow circle with an "!" in the center. I can't find any place in which this icon meaning is documented. I don't receive any error message when I open the task manager nor I see anything abnormal in the processes list.
0
Hi Lazarus, I think it may be that ASUS have changed the location of the config file. Could you first copy the file found at /var/lib/AsusLauncher/simpleui.rc to safe copy then add the lines in the original as Nicholas suggested? You'll have to restart the machine to update the desktop. Then if you could upload the original file here, I can check and modify the installation script to make the changes in that too. Andrew
0
Hi ! Good news ! Of all the simpleui.rc that are infesting the Asus EeePC 901, the right one is the one signalled by Andrew: /var/lib/AsusLauncher/simpleui.rc Inserting the requested "vodafone" lines in the right point allows the GUI to display the Vodafone icon. Now it is apparently all ok. Thankyou everybody for help, professionality and kindness. The second piece of cake is that Vodafone Italy had just phoned me aplogizing for the delay and informed me that they had just sent me my internet key by express delivery. Hope to receive and test it soon! Maybe that you guys can correct the VMC tool offered in the Betavine repository just to allow the 901 models to be updated in the correct simpleui.rc file (the one in /var/lib/AsusLauncher/ and not the others)? Last glitch...is anybody able to understand why my Task Manager Icon is permanently in "SOS" mode (yellow circle with a "!" on top) instead of the default green square ? Thankyou again to all the guys here !
0
Uuueps...I almost forgot... The two cd included in the package are: "Support CD Rev 1.2 - A557" "DVD di ripristino Linux Rev 1.0 - A253" The latter is clearly the restore cd. Kind regards to everybody.
0
Lazarus I am glad that we are getting there; as Andrew has said, it will be a case of testing with the dongle for the remainder of the setup, so, I hope that it does arrive soon for you to play with! I am sure we can get the installer fixed for this; it appears that Asus has changed the file footprint of the EEE's configuration in the 901 (the application was built against the 701's default footprint), which has caused the problem. In terms of the task manager icon, I am not sure, but, I will have a think (will have a look at my EEE) and get back to you, although this might take me a couple of days, as the EEE is no longer my main netbook. Glad that we are making progress; I'm sure we'll have you properly up and running.
0
Hi guys, wanna hear the solution for this mistery ? This night I have reset to factory settings my netbook a huge amount of times just to systematically scan all the possibilities, but now I'm really sure of what I'm going to write. Please, notice that I don't know if this problem is widespread or limited only to Asus EeePC 901 or only to the italian localization of Asus netbook software or both. Before generalization we need to investigate a little bit more, but I can assure that this is exctly the case at least for ....my netbook. Quite simple: installation for vodafone-mobile-connect from the betavine repo is performed almost correctly BUT the simpleui.rc that is updated in order to show the icon linking to the Vodafone connection tool is not the right one in: /var/lib/AsusLauncher/simpleui.rc but the apparently unused one in: /opt/xandros/share/AsusLauncher/simpleui.rc So, starting from scratch, the correct procedure is the following: 1) Install all the asus upgrades requested by your eeepc 901 and reboot if asked to. 2) Follow all the procedure described here: http://www.betavine.net/bvportal/application/linux_drivers/repository 3) kwrite /opt/xandros/share/AsusLauncher/simpleui.rc and locate the block identified by the string "Vodafone" Once selected, copy the entire block (ctrl c) 4) cp /var/lib/AsusLauncher/simpleui.rc ./simpleui.rc.old 5) sudo kwrite /var/lib/AsusLauncher/simpleui.rc Find the first block labelled "Firefox" and insert the previously copied vodafone block (ctrl v) exactly between the identified Firefox block and the following one. 6) Save, Restart and Enjoy. May I suggest to modify the tool in order to have this simpleui.rc update performed automatically by the software? Maybe that this trick even allows to avoid the problem of the removal the Vodafone icon on the Internet tab screen after some software updates? Kind regards, and thankyou to everybody. As soon as I fetch the Internet Key I'll tell you here if all went fine. Have a good night/day/whatever PS: Thankyou Neil. If in the following days you can remember to check about the task manager icon I'll be glad for this too !

Login and answer the question