beta
Hello developer. Login with your existing account. New to Vodafone Developer? Register your account.

+ Login or create an account

0

I got a Vodafone K3760 at some point in Debian/Lenny's lifetime, for use with a Lenovo S10e. I installed (from the Vodafone BetaVine site) usb-modeswitch 0.97 and vodafone-mobile-connect (VMC) 2.10.01-1 (or maybe it was actually vodafone-mobile-connect_svn20090615) and it all worked pretty well.

After the Debian/Squeeze update (2.6.32 kernel) I had some problems. Unlike Lenny, Squeeze includes usb_modeswitch 1.1.4-2, and I also grabbed vodafone-mobile-connect 2.25.01 (the latest version on Betavine targetting Debian-world distros). It does actually work... for a few minutes if you're lucky, before recurring kernel errors cause system lockup. However, with wired or wifi connectivity, the system works perfectly and is stable.

Enquiries in another forum led me to try the 2.6.37 kernel from Debian/Sid, and indeed VMC works perfectly with that.

This is a fine workround for now, but it'd be nicer to have a 100% Squeeze solution (I have little doubt that at some point over the lifetime of Squeeze, Wheezy/Sid will move on to the point that just saying "use the kernel from..." is no longer a viable solution). Is Debian/Squeeze's 2.6.32 kernel support for whatever VMC uses just plain broken ? Or is there something I can reconfigure in Squeeze/Squeeze's 2.6.32 kernel which might fix this up ? Is it my hardware (I'd be interested to hear if someone is using VMC with unmodified Squeeze anywhere).

Update 28/03/2011: Had a small hope that the 6.0.1 update to Squeeze (with minor a bump of the kernel from 2.6.32-30 to -31) might make things work better than the initial 6.0 release but no joy (any network traffic more substantial than ping quickly hangs system). So I tracked the sid kernel on up to 2.6.38-1-686 and VMC continues to work well with that.

Update 07/07/2012: I have another vanilla Debian/squeeze laptop I wanted to use the dongle with and thought I would try BCM on it instead of VCM this time (see one of the answers below). Made sure an older Python 2.5 was uninstalled and I just had Python 2.6 (saw a thread about this on the Forge site somwhere), then Installed the "beta 3" 2.99.12-1 deb with the accompanying python-messaging and wader-core (but not the modeswitch) and a few missing dependencies (e.g wmctrl and python-gudev) from squeeze... and it seems to be working very well. The most obvious oddity is that "Usage" always seems to log against the "3G" total even when connected by GPRS.

edited 2 years ago
add comment
  1. Hi Timday, Thanks for the datapoint about the usage logging, I've some fixes pending regarding usage that haven't currently made it into packages, so it's possible that it's already been fixed, but I'll certainly add it to my things to check before the next release. Thanks, Andrew - (2 years, 9 months ago) andrewbird

5 Answers:

1

Hi TimDay, I suspect that this issue is caused by contention between VMC and Modem Manager over the modem's status port. The HSO driver used by the K3760 is not particularly robust in this regard. I heard of a proprietary solution that had a similar problem. See this bug: Ubuntu bug with K3760 and kernel 2.6.32 You might try Wader-core and BCM (VMC's replacement), as they were rewritten to play nicely with Network Manager / Modem Manager. Betavine forge site for BCM

Hope it helps,

Andrew

1 comment
  1. Thanks. Yes that looks like it's the same problem I was seeing. I'd completely failed to register the existence of BCM; not tried yet but could be the VMC replacement I was looking for. Is VMC just expected to fade into obsolescence now ? - (3 years, 1 month ago) TimDay
0

There are a Huge Range of Wholesale Fashion Watches include Cool Watches for Mens, Womens and kids and cheap watches for Sale. Buy Wrist Watches ...

0

Hi tydaikho, I guess there's a graphical user manager tool on Debian. Check it for the group memberships your username has. If you need to add yourself to dialout and lock groups, make sure you logout and back in to collect the new privileges.

Hope it helps,

Andrew

2 comments
  1. I have add myself with command: addgroup abcz dialout and get : The user `abcz' is already a member of `dialout'. Try to check: grep abcz /etc/group i get: dialout:x:20:smsd,gsmsms,abcz But i get no "lock" group on my system ... I have reboot mystem but the problem is not fixed ... Thank you ! - (2 years, 11 months ago) tydaikho
  2. Any your ideal, sir! The problem still exists ... I have been added to dialout group, restart system...But i always get that message when i run vodafone-connect ... Thank you sir! - (2 years, 11 months ago) tydaikho
0

I get Permissions Problem when i run VMC on Debian ...

======================== It appears that you do not have privillages to run the Vodafone Mobile Connect application. You need to be part of the groups 'dialout' and 'lock' to run the Modem Manager. If you have already added yourself to those groups, try restarting the computer or logging in as yourself to activate your changes. ========================\

Eventual, my username is included in dialout group... How can i fix this error? Thank you !

0

Hi Tim, Well BCM is pretty much just the VMC interface implemented on top of a redesigned core. I expect that VMC will stay around for those netbooks that are based on older distros, but all new development will be on BCM. I'm not sure about whether effort will be applied into getting new modem devices working on both.

Best regards,

Andrew

Login and answer the question